Why isn’t My Pre-chat Survey Displaying to My Site Visitors

Problem

I want my site visitors to fill in a pre-chat survey before starting a chat. However, on my website, the chat starts immediately after visitors click on the chat button. How can I change that?


Cause

The following could be the possible cause:

  • Your pre-chat form is not enabled for the campaign you are using on your website.
  • Pre-Chat is enabled for a different campaign.


Solution

  1. Log in to the Comm100 account.
  2. From the left navigation menu, go to Live Chat > Campaign.
  3. Select your campaign from the drop-down list, and go to Pre-Chat.
  4. Turn on the Pre-chat toggle key.kb-prechat-01.png
  5. Select the fields you want your visitors to fill in and mark them visible. Mark the mandatory fields as Required.kb-prechat-02.png
  6. Click Save. 

If you need further assistance, contact the Comm100 Support team