Why Can’t I Receive Push Notifications on My Android Phone

Problem

I can use the Comm100 app on my Android phone, however, I cannot receive push notifications for chat messages and new visitors.


Cause 

The following are possible reasons that you cannot receive push notifications of the Comm100 app on an Android device:

  • The notification for chat events is disabled in the Comm100 app. 
  • The notification for the Comm100 app is disabled in your phone settings. 
  • The lock screen notifications are disabled on your phone so that you cannot receive any notifications on the lock screen.
  • Power saving settings of your phone interrupt Comm100 app notifications. 
  • Your phone’s data saver prevents the Comm100 app from sending and receiving data in the background.


Solution

Check the following settings and your access to Google services.

Note: The menu name for your phone settings may vary depending on your device and version.
  • Check your app notification settings.
    In the Comm100 app, tap Settings > Notification, verify that the notifications for the corresponding chat events are enabled.
    kb-appNotification-02.jpg
  • Check your phone’s notification settings for the Comm100 app.
    Go to your phone’s Settings > Notifications, find the Comm100 app, verify that notification is enabled. 
  • Verify that lock screen notifications are enabled on your phone.
    Go to your phone’s Settings > Notifications, verify that lock screen notifications are enabled. The following shows an example:
    kb-appNotification-05.jpg
  • Verify that no power saving mode is preventing the Comm100 app from running.
    Go to your phone’s Settings > Battery, verify that Power Saving mode or Battery Optimization settings do not restrict the Comm100 app or background activities. In the following example, make sure Ultra Power Saving mode is not enabled.
    kb-appNotification-06.jpg
    Note: The exact settings and options may vary depending on your phone model. 
  • Ensure that no data saving settings are restricting the Comm100 app.
    Go to Settings > Data Usage, verify that Data Saver is disabled. The data saver feature can prevent the apps from sending and receiving data in the background. The following shows an example:
    kb-appNotification-04.jpg